CSV exported file from Jira search is resulting empty file

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Exporting issues from Global Issue search and Project Issue search resulted in an empty csv file.

Environment

Jira cloud

Diagnosis

To verify the root cause please perform the following check: 

  1. Attempt to export the issues with all options like "Export CSV(my defaults)" or "Export CSV(all fields)"  and "Export Excel CSV(my defaults)" or "Export Excel CSV(all fields)", it should result in exporting empty CSV file. For "Export CSV(my defaults)" and "Export Excel CSV(my defaults)"  select minimal system field as the default column like Issue key, Summary and perform the export, it should result in empty csv file.

  2. Performing import from other formats possible like XML or Word should give this outcome:

Exported XML:

1 2 3 4 5 6 7 8 9 This XML file does not appear to have any style information associated with it. The document tree is shown below. <!-- RSS generated by JIRA (1001.0.0-SNAPSHOT#100262-rev:c076123891a237f43b1d083c7eff35608c543d69) at Thu Aug 22 16:07:05 UTC 2024 It is possible to restrict the fields that are returned in this document by specifying the 'field' parameter in your request. For example, to request only the issue key and summary add field=key&field=summary to the URL of your request. --><!-- If you wish to do custom client-side styling of RSS, uncomment this: <?xml-stylesheet href="<base-url>/styles/jiraxml2html.xsl" type="text/xsl"?> --><rss version="0.92"><channel><title>Test Instance</title><link>https://TestInstance.atlassian.net/issues/?jql=project+%3D+%22TIRASK%22+ORDER+BY+created+DESC</link><description>An XML representation of a search request</description><language>en-us</language><issue start="0" end="0" total="0"/><build-info><version>1001.0.0-SNAPSHOT</version><build-number>100262</build-number><build-date>22-08-2024</build-date></build-info></channel></rss>

Cause

If the data export is set as “Block export” then the export file should result with an empty record file. Here is the documentation: Prevent data export

Solution

It is recommended to change the Data export setting to "Allow export" that should resolve problem.

Updated on March 14, 2025

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