Workday connector sync error: Organization doesn't exist

This page helps you resolve a synchronization error where a position is associated with a supervisory organization that can't be found.

Symptom

When syncing users with the Workday connector, the sync fails and you see the following error in your logs:

Position with external ID {externalId} is associated with an organization that doesn't exist

Cause

This error occurs when the Workday connector can't resolve the relationship between a position and its supervisory organization. This is usually because the organization is missing or there is a mismatch between the IDs used in the Workday positions and organizations reports.

Resolution

To resolve this issue, you must verify that both the position and its associated organization are correctly included in your Workday reports.

Step 1: Verify the position and organization IDs

  1. Open your positions and organizations reports in Workday.

  2. In the positions report, search for the positionId that matches the {externalId} from the error message.

  3. Copy the supervisoryOrganizationId value for that position.

  4. In the organizations report, search for an organizationId that matches the supervisoryOrganizationId you just copied.

Step 2: Fix report mismatches

Depending on what you found in Step 1, take one of the following actions:

  • If the organization is missing: Update your organizations report to include the organization with the missing organizationId.

  • If the ID is incorrect: Update the affected position in your positions report to reference a supervisoryOrganizationId that exists in your organizations report.

Step 3: Re-sync

  1. Go back to the Workday connector in Atlassian Administration (Connected apps > Workday).

  2. Select the Settings tab.

  3. Select Sync now to sync the update that fixes the error.

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