Workday connector sync error: Duplicate organization IDs
This page helps you resolve a synchronization error where multiple active organizations in Workday share the same external ID.
Symptom
When syncing users with the Workday app, the sync fails and you see the following error in your Talent logs:
Organization with external ID {externalId} - externalId: Duplicate id. Organization ids must be unique
Cause
Talent requires every active organization to have a unique externalId. This error occurs when your Workday organizations custom report contains multiple active organizations with the same organizationId.
Resolution
To resolve this issue, you must identify the duplicate ids in your Workday organizations report and ensure only one is marked as active.
Step 1: Identify the affected organizations
Open your organizations report in Workday.
Search for the
organizationIdthat matches the{externalId}provided in the error message.If you find only one organization (or none), the report data may have been updated since the last sync attempt. Try to re-sync the app to see if the issue is resolved.
If you find multiple organizations with the same ID, check the
isActivefield for each.If only one organization has an
isActivevalue of1, try to re-sync the app. If multiple organizations are marked as1, continue to the next step.
Step 2: Fix the duplicate IDs
You can resolve this in one of two ways:
Update your organizations report in Workday to remove or change duplicate
organizationIdvalues so that each active organization is unique.Update the report so that only one organization with that ID has an
isActivevalue of1. Set all other duplicates to0.
Step 3: Re-sync
Go back to the Workday connector in Atlassian Administration (Connected apps > Workday).
Select the Settings tab.
Select Sync now to sync the update that fixes the error.
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