Workday connector sync error: Duplicate emails
This page helps you resolve a synchronization error where multiple active workers in Workday share the same email address.
Symptom
When syncing users with the Workday app, the sync fails and you see the following error in your Talent logs:
Worker with external ID {externalId} - email: Duplicate email. Emails must be unique
Cause
Talent requires every active worker to have a unique email address. This error occurs when your Workday workers custom report contains multiple workers with the same email address.
Resolution
To resolve this issue, you must identify the duplicate email addresses in your Workday workers report and ensure each worker has a unique entry.
Step 1: Identify the affected workers
Open your workers report in Workday.
Search for the email address associated with the
{externalId}provided in the error message.If you find only one worker (or none), the report data may have been updated since the last sync attempt. Try to re-sync the connector to see if the issue is resolved.
If you find multiple workers with the same email address, continue to the next step.
Step 2: Fix the duplicate emails and re-sync
Update your workers report in Workday to remove or change duplicate email values so that each active worker has a unique email address.
Go back to the Workday connector in Atlassian Administration (Connected apps > Workday).
Select the Settings tab.
Select Sync now to sync the update that fixes the error.
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