Work Items or Comments processed by JSM from emails are missing content from the original messages

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Work Items/Comments generated by emails processed on JSM Mail Handler do not present the full contents of the original message.

Cause

When users send a message into the JSM email channel, any quoted information (within <div> tags or forwarded email thread) are removed if strip quote settings are enabled. The EML File that generated the comment/work item will be available at the JSM Mail Handler processing logs and can be used to assist on troubleshooting the possible causes:

  • Opening the EML at a text editor will allow to search for all <div> tags that may contain a quote class, such as <div class=3D"gmail_quote gmail_quote_container">, or <blockquote class=3D"gmail_quote" ...>

  • Forwarding emails into JSM email channel will have similar result, only the information on the message sent by the user will be added as part of the comment/work item summary, the appended email thread will be pruned

Solution

Educate users to avoid copying/forwarding content from existing email threads, or when necessary, be sure to clear any existing formatting. A brand new email is always recommended when creating new requests.

Alternatively, Jira Admins may disable site-wide strip quote settings (this may result on cluttering of other messages, as entire mail threads may be processed).

The following feature requests aim to improve/ the Strip Quote settings:

JSDCLOUD-14204

JSDCLOUD-2356

JSDCLOUD-12216

Updated on April 14, 2025

Still need help?

The Atlassian Community is here for you.