Adding new Slack Workspace for Incident Management results in "We couldn't connect the workspace" error message.

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When you are connecting a Slack Workspace for Incident Management by following the steps in Connect a new Slack workspace to your service project you see the below error:

(Auto-migrated image: description temporarily unavailable)

Environment

Jira Service Management Cloud.

Cause

We run into this error due to permission issues with Jira or incorrect permissions set in Slack or Licensing.

Solution

When adding the Slack workspace for Incident Management make sure the below conditions are met:

Jira permissions:

Slack permissions:

In case you are still facing an issue with adding a Slack workspace feel free to contact support via the Support portal.

Updated on April 14, 2025

Still need help?

The Atlassian Community is here for you.