Resolve mismatched Space counts in Confluence Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When you compare the spaces listed in the Space permissions menu with those in the space directory, you might notice a difference in the number of spaces.
Comparing lists
There are more spaces under the Space permissions list. Follow these steps to compare the lists:
Checking the Space Permissions option
As an administrator of Confluence, tap the gear icon at the top-right
While on the administration, tap Space Permissions on the sidebar.
Check the list of spaces.
Checking the Space directory
Select Spaces from the navigation bar.
Select View all space from the drop-down menu.
Alternatively, select the View all button for the spaces list on Confluence's home page.
Diagnosis
Under the Space permissions option, check if the spaces that are not visible have the Recover permission button on their right side. This would indicate that the space is restricted.
Check the status of the space to confirm if this is not an archived space.
Cause
There are different reasons for seeing more spaces in the Space permissions:
This option lists spaces where the user does not have permission to view. These spaces can be identified when they have the Recover space permissions button, like the example below:
The spaces are under the Archived status. Archived spaces will not be displayed in the space directory.
There could be an indexing issue.
ℹ️ Another difference is that the space directory lists personal spaces, not included in the Space permissions option.
Solution
For each of the cases, different solutions can be followed:
Select the Recover space permissions button while navigating through the Space permissions option. This will grant the user administration and view permissions.
Unarchive the space by accessing the space in question > Space settings > Edit space details and change the Status to Current.
For the re-indexing issue, as this is a Restricted function to Atlassian support, contact the support team for a re-index via https://support.atlassian.com/contact/
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