Popular macro displayed as unknown on Confluence Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

After migrating from Confluence Server to Cloud, the Popular content macro (which is part of the Confluence Usage Tracking Plugin) is no longer rendering due to an "unknown macro" placeholder.

In this case, the macro is from the Confluence Usage Tracking Plugin, which is not enabled by default in the Confluence server and is not available in Confluence Cloud.

Diagnosis

  • While using the macro browser, search for the "Popular" macro and confirm that this is not displayed as a different macro as well.

  • Confirm that no other macros from the Confluence Usage Tracking Plugin are available (I.E. usagetopusers).

Cause

While this macro is available in Confluence Server by manually enabling it, it is not available in Cloud, meaning that the "unknown" placeholder is a result confirming that the macro does not exist.

Solution

While there is no clear solution, there are some alternatives in Confluence Cloud that could help with statistics:

Updated on February 27, 2025

Still need help?

The Atlassian Community is here for you.