How do we delete user accounts on our email domain

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

How do I delete the Bitbucket account of an employee registered with the email having the company domain after they have left the company as an Administrator?

Diagnosis

If the users/employees in your organization sign up for Bitbucket using their corporate email such as user1@company.com and leaves the organization later, there sometimes arises a situation where you will have to delete their account from your end without the help of Support (Or delete the account for other reasons). As an administrator, there might be requirements to have the permissions to have autonomous control over deleting the accounts among other activities.

Solution

This is possible if you have a managed account. To convert all the users registered with the company domain into managed accounts, follow the below steps -

Warning

Note -  Deleting an account from Admin Hub results in all associated cloud accounts deletion. You can refer to our documentation for Atlassian account deletion.

Once you claim the domain and convert the un-managed accounts into managed accounts, you also have other permissions such as changing the email address etc.

Warning

If you do not want to make all the accounts managed or create an organization, the only other way is to request the user to directly delete their account or if you have the user's credentials, you can sign in and delete the account.

Updated on April 8, 2025

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