Unable to complete JSM chat setup on MS Teams or Slack - Cloud Only

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When trying to complete the JSM chat setup on MS Teams or Slack, you are unable to continue with the channel configuration, or the message "Something went wrong. Please try again later" is displayed.

Diagnosis

Confirm the installation of "Atlassian Assist"

  1. Log in to your Atlassian application as a user with administrative privileges. 

  2. From the top navigation bar in your application, select Apps, and then Manage apps.

  3. If the drop-down defaults to User-installed, check Action required.

  4. Click the Update button next to “Atlassian Assist”. This will show the error message as below in the user-installed apps section: “The app 'halp.com' could not be installed as a local app as it has previously been installed from Atlassian Marketplace.

Cause

Atlassian Assist” shows up in the user-installed apps section instead of System apps.

Solution

Please use the following steps to recover from this situation:

  1. This may be a temporary issue following the migration. After some time, please recheck, and the app should appear under System Apps.

  2. If this happens on a working setup, remove Assist from any existing Triage & Request Channels using /remove @Assist.

  3. From your service project, select Project settings, then Channels & self service, then Chat. Click on the three meatballs (⋯) next to the workspace, and “Disconnect this project,” and try to connect again.

  4. Re-add Assist using /add @Assist to the channels and reconnect the workspace as outlined here:

  5. If you've attempted to connect to the same or a different workspace multiple times, refrain from making additional retries. Instead, wait a while, then log out of your Atlassian account. After logging out, retry the setup from an incognito browser window.

  6. If the issue persists, we may need to reinstall Assist on the site, which refreshes the permissions. Please contact Atlassian support to perform this for you.

Updated on June 13, 2025

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