Unable to add Teams as Service Owners

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

After creating/ editing a Service and trying to add a new Team as the Service Owners, the new Team is not available in the drop-down menu:

(Auto-migrated image: description temporarily unavailable)

Cause

To start using the newly created Team, it is required to start your team’s operations first.

Solution

Go to your newly created team and you should see the following option:

(Auto-migrated image: description temporarily unavailable)

Follow the wizard steps until you Confirm the new Team:

(Auto-migrated image: description temporarily unavailable)

Once completed, you should see the new Team available under Service Owners within your Service.

References:

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.