Unable find the inactive user to remove their membership from Bitbucket Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

The workspace admin can export their user list from the workspace settings. There are some users who are in the INACTIVE state but unable to find them in the "User Directory".

Cause

The inactive account could be an organization-managed account which is in the deactivated status. As Bitbucket Cloud accounts are linked to Atlassian Accounts, the deactivation of Atlassian accounts will also result in the deactivation of their Bitbucket Accounts making their account an "Inactive" status. Therefore, the users will be no longer able to access their Bitbucket account to access any of the workspaces they had access to earlier.

Solution

As the account is organization-managed, the organization admin can activate their Atlassian account using "Reactivate Account" from Atlassian Admin Hub or Delete the managed account which would automatically remove their Bitbucket account as well.

ℹ️ Please note that inactive users are not counted towards billing.

Updated on April 24, 2025

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