What happens when you exceed your user license limit in Confluence Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

For customers who are on annual subscriptions, when you exceed your user-tier license limit, users will experience reduced functionality for Confluence (I.E. edit the description of spaces or create personal spaces), but it does not mean that the site will become read-only, as it happens in Confluence Data Center/Server.

When it happens in Cloud, you would need to either contact us to upgrade the product license tier or remove licenses from existing users.

ℹ️ Note that the users should still be able to create spaces and pages, allowing them to also edit existing pages.

Diagnosis

  • When trying to add new users for Confluence, the following message is displayed:

You've reached the maximum number of users for your plan. To add this user, upgrade your plan.

(Auto-migrated image: description temporarily unavailable)
(Auto-migrated image: description temporarily unavailable)

Cause

When using Atlassian Guard for user management so new users are added via user provisioning, and new users will be added to the site and consume product licenses. This behavior is explained in the following closed bug:

Solution

There are two options available to resolve this issue:

  1. Upgrade your current annual license subscription to a higher user tier.

2. Reduce the number of users consuming a Jira or Confluence Cloud license.

To remove license allocations from one or more existing users:

  1. Log in to admin.atlassian.com

  2. Select the site that you want to remove the users from.

  3. For the Users, you want to remove product access, click on the (…) button and select Show Product Access.

  4. Uncheck the box next to the product to remove both license allocation and access from the user.

  5. Click Save to confirm the changes.

Updated on April 7, 2025

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