"We couldn't replace the workflow" error thrown while trying to change the issue type of change management request type

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Unable to change the workflow for the change management request type following steps from Change the workflow and issue type of a request type results in the below error.

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Environment

Jira Service Management Cloud

Diagnosis

Error seen in developer tools.

1 2 3 4 5 6 Request URL: https://bqetrack.atlassian.net/rest/servicedesk/1/servicedesk/10857/request-type/19/workflow Request Method: POST Status Code: 500 Internal Server Error

Cause

  • The Work Category field which is default added to the Change issue type and screens, can't be added to the different issue types manually. This field stops the change and throws the error.

Solution

  • Please remove the Work Category field from the Request Type ( for which you wish to change the issue type ) screens and then perform the change.

  • You will now be able to change the workflow.

Updated on March 3, 2025

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