Unable to set "Assignee" field as Optional in field configuration
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When the Assignee field is set as Required, it is not possible to remove it from the request form or Jira issue view without making it optional.
If the field is marked as Required at a request type level, it can be changed to optional. However, unlike other fields, in scenarios where this field is made "Required" from the field configuration, we do not get an option to make it " Optional."
Environment
Jira Service Management Cloud
Diagnosis
Confirm that the field is not marked as Required only at the request type level. To do this, go to your associated field configuration and check if the field "Assignee" is shown as Required.
Unlike other fields, the "Assignee" field can't be made Required /Optional from the field configuration as we don't see an option to do so.
Also, in the request form, the Assignee field will be Required and has a default value set. When trying to remove it from the form, it will return the error: "You can't remove this field. Jira Service Management created this field. You can't remove it."
Cause
Jira provides a global setting to Allow unassigned issues. When turned ON, the default assignee for the project is Unassigned. When turned OFF, issues must always be assigned to someone - by default, the assignee will be the Project Lead as defined for each project
So when this setting is set to OFF, issues cannot be left unassigned and as a result, the field becomes required in all the field configurations and can no longer be set as Optional.
Solution
To set the field Assignee as Optional, change the above setting to ON :
Go to https://<Site-Name>/jira/settings/system/general-configuration.
Click on Edit and set Allow unassigned issues to ON.
Click Update to save the changes.
This will allow the field "Assignee" to be left Unassigned and hence, will make the field Optional in your field configuration.
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