Unable to search for list of customers in JSM Cloud customer portal

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When you want to share a request with other customers, you notice that the list of users doesn't show up when you type the first or second letter. It happens for the user picker field and "Share with" field. You will need to key in the email address to make it work.

Diagnosis

The list of users is not showing up unless you enter the user's email address.

Cause

The customer sharing option under Project settings > Customer permission is using:

1 Customers can search for other customers within their organizations, or manually enter the email address of other customers within their project

The above option will enable users to search for other customers within their organizations. If the customer you are looking for is not within the same Organization as you, you will need to key in their email address to add them. 

Solution

The solution below will enable your customers to search for other customers outside their organizations within the same project. Only use this, if the project is for an internal company/staff usage where you don't mind having all customers within the project to be able to search for one another. 

  1. From your service project, go to Project settings > Customer permissions > Customer sharing.

  2. Select Customers can search for other customers within their project or organizations

For more information about managing your customer permission, please visit Change project customer permissions.

Updated on February 28, 2025

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