Unable to render element error in navigation bar after upgrading Jira Service Management

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

After upgrading to Jira Service Management 3.2.x or greater, observe the problems below while browsing a Service Management project.

  • The project navigation bar will not render properly with message Unable to render element due to an error on top of the bar.

(Auto-migrated image: description temporarily unavailable)
  • Restricted to view any Service Management related administration settings: Request types, Request security, Portal settings, Satisfaction settings, Email requests, Knowledge base, SLAs and Automation.

    (Auto-migrated image: description temporarily unavailable)

Diagnosis

Cause 1

  • The following appears in the atlassian-jira.log

    1 2 3 4 5 6 7 8 2016-08-30 22:12:51,923 http-nio-8320-exec-11 ERROR anonymous 1332x78x3 8rur7t 0:0:0:0:0:0:0:1 /browse/DESK [c.a.p.webresource.assembler.DefaultWebResourceAssembler] Error generating bigpipe content for 'sidebar-id': java.lang.NullPointerException java.util.concurrent.CompletionException: java.lang.NullPointerException at java.util.concurrent.CompletableFuture.encodeThrowable(CompletableFuture.java:273) at java.util.concurrent.CompletableFuture.completeThrowable(CompletableFuture.java:280) at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1592) at com.atlassian.jira.plugin.bigpipe.PrioritizedRunnable.run(PrioritizedRunnable.java:31) at com.atlassian.jira.plugin.bigpipe.BigPipeService.lambda$executeSingleTask$1(BigPipeService.java:59) at java.util.Optional.map(Optional.java:215)
  • The following appears in the atlassian-servicedesk.log

    1 2016-08-30 22:10:07,438 UpmAsynchronousTaskManager:thread-1 ERROR anonymous 1332x78x3 8rur7t 0:0:0:0:0:0:0:1 /rest/plugins/1.0/available/featured [atlassian.servicedesk.bootstrap.lifecycle] '2.3.6' version of Service Management cannot be upgraded to '3.2.0-038-01'. Upgrade to '3.0.0' <= <version> < '3.2.0' first. com.atlassian.servicedesk.bootstrap.upgrade.UnsatisfiedVersionRequirementException: '2.3.6' version of Service Management cannot be upgraded to '3.2.0-038-01'. Upgrade to '3.0.0' <= <version> < '3.2.0' first. at com.atlassian.servicedesk.bootstrap.upgrade.UpgradeRequirementsChecker.checkVersionRequirementForUpgrade(UpgradeRequirementsChecker.java:25) at com.atlassian.servicedesk.bootstrap.lifecycle.PluginLifeCycle.checkAndRunUpgrades(PluginLifeCycle.java:256) at com.atlassian.servicedesk.bootstrap.lifecycle.PluginLifeCycle.runPluginStartupSideEffectsImpl(PluginLifeCycle.java:183) at com.atlassian.servicedesk.bootstrap.lifecycle.LifecycleLock.writeImpl(LifecycleLock.java:97) at com.atlassian.servicedesk.bootstrap.lifecycle.LifecycleLock.runOnStartup(LifecycleLock.java:75)

Cause 2

  • The following appears in the atlassian-jira.log

    1 2 [c.a.p.webresource.assembler.DefaultWebResourceAssembler] Error generating bigpipe content for 'sidebar-id': Deadline exceeded Error generating bigpipe content for 'activity-panel-pipe-id': Deadline exceeded

Solution

Cause 1

 Unfulfilled upgrade requirements. The minimum version to upgrade to Jira Service Desk 3.2.x or greater is 3.0.x/3.1.x, this has also been stated in the FIZME upgrade notes.

If Jira has been upgraded to 7.0.x/3.0.x or 7.1.x/3.1.x before, please check the following KB instead:

Prevention

  • Upgrade to at least Jira 7.0.x with Service Management 3.0.x before upgrading to Jira 7.2.x with Service Management 3.2.x or any other version after these.

Prequisite

To be able to execute the following steps make sure that your Jira is on Downngrade Version: <= 7.1.9

You can find the downgrade version in system info page: Jira Administration > System > Look for the line "jira.downgrade.minimum.version"

If you have upgraded to 7.2.x / 3.2.x

Follow these steps to downgrade from 7.2.x to 7.1.9 with SD 3.1.9 before upgrading back to 7.2.x:

  1. Download the JiraServiceDesk 3.1.9 Server installer from one of the links below to install Jira Core 7.1.9 +ServiceDesk 3.1.9.

  2. Install Jira Service Management Server 3.1.9 as a new separate standalone instance as a medium for the 'upgrade'. That being said, there should be a new Jira_Home, Jira_Installation, and new database for this Service Management 3.1.9 instance.

  3. Once this new instance (3.1.9) is ready, shut it down.

  4. Allocate adequate application memory as per the Jira Sizing Guide and set the flag -Djira.downgrade.allowed=true to JSD 3.1.9 instance as per: Setting properties and options on startup

    This is to allow the downgrade to run properly.

  5. Start the new 3.1.9 instance.

  6. Take a latest XML backup from 7.2.x.

    Please prepare a maintainence window to do this, so that you can prevent users from accessing Jira and creating/updating tickets - otherwise, you will lose those data as they won't be included in the XML backup.

  7. Restore the backup into the new 3.1.9 instance.

    There will be a message that needs to be acknowledged on the UI after selecting the backup for restoration. Acknowledge it, verify the correct backup file has been chosen and then click on the Restore button again to kick start the restoration process.

  8. Once done, admin will be logged out. Re-login to the 3.1.9 instance, ensure SD application is installed and licensed, and Agent features are available.

  9. Take an XML backup from 3.1.9 (good data) and restore it back to 7.2.x.

  10. If errors persist a Rollback is required please refer to the workaround described in JSDSERVER-4211 - Upgrading Service Desk to 3.2 from a version <= 2.5.x causes the sidebar to appear blank with an error 'unable to render element due to an error'

If you have upgraded to 3.3.x then you will need to use the workaround in JRASERVER-63367 - Cloud to server import fails with 'could not find entity' errors in logs

  1. Download the JiraServiceDesk 3.1.9 Server installer from one of the links below to install Jira Core 7.1.9 +ServiceDesk 3.1.9.

  2. Install Jira Service Management Server 3.1.9 as a new separate standalone instance as a medium for the 'upgrade'. That being said, there should be a new Jira_Home, Jira_Installation, and new database for this Service Management 3.1.9 instance.

  3. Once this new instance (3.1.9) is ready, shut it down.

  4. Allocate adequate application memory as per the Jira Sizing Guide.

    To increase the application memory, please refer to Increasing Jira application memory.

  5. Set the flag -Djira.downgrade.allowed=true to JSD 3.1.9 instance as per: Setting properties and options on startup

    This is important in order to allow the downgrade to run properly.

  6. Start the new 3.1.9 instance.

  7. Take a latest XML backup from 7.3.x.

    Please prepare a maintainence window to do this, so that you can prevent users from accessing Jira and creating/updating tickets - otherwise, you will lose those data as they won't be included in the XML backup.

  8. Perform the workaround in JRASERVER-63367 - Cloud to server import fails with 'could not find entity' errors in logs

  9. Restore the backup into the new 3.1.9 instance.

    There will be a message that needs to be acknowledged on the UI after selecting the backup for restoration. Acknowledge it, verify the correct backup file has been chosen and then click on the Restore button again to kick start the restoration process.

  10. Once done, admin will be logged out. Re-log in to the 3.1.9 instance, ensure SD application is installed and licensed, and Agent features are available.

    The steps below are optional to ensure the data will be downgraded completely in case the downgrade flag in step 3 above is not effective.

    1. Uninstall Service Management application and license from the 3.1.9 instance.

    2. Restart the 3.1.9 instance.

    3. Re-installServiceDesk application v3.1.9 and apply the license.

  11. Take an XML backup from 3.1.9 (good data) and restore itbackto 7.3.x.

  12. If errors persist a Rollback is required please refer to the workaround described in JSDSERVER-4211 - Upgrading Service Desk to 3.2 from a version <= 2.5.x causes the sidebar to appear blank with an error 'unable to render element due to an error'

Cause 2

In Jira 7.2 there were some changes made to the way that certain elements were rendered.

See related bug for more details: JRASERVER-64095 - Sidebar fails to display with 'Unable to render element due to an error' message when viewing issue due to BigPipe timeouts

Updated on April 16, 2025

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