Unable to remove Slack connection in JSM Incident Management tools

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When trying to remove the Slack connection for JSM Incident Management tools on:

  1. Settings > Products.

  2. Under the Jira Service Management heading, go to Incident management tools.

  3. In the Slack section, find the workspace you’d like to remove and select Remove.

  4. Select Remove.

Sometimes, you can face the following error:

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"We couldn't remove the workspace

Failed to delete connection due to its association with Jira project"

Cause

The system does not allow you to remove the Slack connection because it's being used by a project.

Solution

In order to identify which project is using the Slack connection, we can follow the below steps:

  1. Enable the browser developer tools

  2. In Google Chrome used as example, click the ••• button to the right of the address bar and select More Tools > Developer Tools

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  3. Click on the Network tab, and try to remove the Slack connection again

  4. You should see a 400 error in red

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  5. Click on the message in red, and then check the Response tab

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  6. It will show the project ID that's using the Slack connection

  7. You can open any project in Jira and go to Project settings > Details

  8. The project ID will be available on the URL, you just need to change it for the ID you've found on step 5.

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  9. In order to find the Slack connection for the project, go to Project settings > Features and enable the Incident Management feature

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  10. And, to disable the Slack connection for the project, go to Project settings > Incident Management

  11. Under Communication preferences, you should see a Slack connection

  12. Expand it and remove the connection

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After removing the Slack connection from the project, you should be able to remove the connection from the product level.

Updated on May 22, 2025

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