Unable to change Issue Security on an existing issue

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Despite having an Issue Security configured on the project and having the permission to set the security levels, it's still possible for a user to not be able to edit the security level on some issues of specific Issue Types but may be able to edit them on other Issue Types.

Environment

Jira Cloud (All project types)

Cause

Each Issue Type within a project may be configured to have its own screen configuration and only fields configured on the screen will be available for the actions. In this case, changing the security level is an Edit Issue action, requiring the Security Level field to be configured in the Edit Issue screen of said Issue Type.

Solution

To update the screen, follow the steps below:

  • Open the project

  • Go to Project settings > Screens

  • Expand the screen scheme for the affected Issue Type

  • Next, click on the screen link under the Screen column for the Edit issue operation.

(Auto-migrated image: description temporarily unavailable)
  • At the bottom of the list, find and select the *Security Level* field in the 'Find field' option.

(Auto-migrated image: description temporarily unavailable)
  • As a result, you're now able to edit the "Security Level" for the existing issue.

(Auto-migrated image: description temporarily unavailable)
Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.