Jira Cloud: 'Internal server error' on Transition Screen When Transitioning Work Items
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Sometimes, when you use the workflow post function Clear Field Value for the Assignee field, and also transition the issue that uses a work item screen, the error message "Internal server error" may be displayed when confirming the entered screen data, for example:

Cause
This issue occurs because the database mistakenly points the assignee field to a user who is no longer part of your site. While in the UI, there is no such configuration inside the post function; however, it is still recorded in the database. This means at one point the configuration did exist but wasn't deleted properly from the database when removed from UI.
Solution
In order to resolve this issue, access the affected issue type workflow:
Select ⚙ > Work Items.
Select Workflows.
Select the workflow transition that's facing the "Internal server error" message and click Edit.
In the Workflow Editor, select the transition.
Select 'Post Functions' in the properties panel
Afterwards, proceed with the following steps:
Remove post function Clear Field Value for the Assignee field
Add the Assign the issue to the lead developer post function.
Publish the workflow.
Edit the workflow again.
Delete the Assign the issue to the lead developer post function.
Add the post function Clear Field Value for the Assignee field
Publish the workflow.
This will re-sync the post-function data, allowing the successful transition of the issue to the target status.
Relevant links
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