Something went wrong error when trying to create a Team in Jira Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

No Jira Cloud users can create a new Team on the site. When they try, they see the error below:

"Sorry, something went wrong. We couldn't save your team. Please try again."

The create a team option as found in Jira's navigation header.

Diagnosis

When reproducing the error message, if a user opens their browser's development tools, the below error message will appear:

{ "messages":  ["User cannot access team"] }

Cause

Admin approval allows for organization access

If no products in the Atlassian Cloud Organization require Admin approval, none of the users are considered to have access to the organization.

Because Teams are an Organization concept, if a user doesn't have access to the Organization in this way, they also can't create Teams. For more details, please refer to our documentation on Atlassian Team visibility.

Solution

Ensure your Organization includes at least one product requiring Admin approval

With at least one non-open access product, your users will be considered to have access to the Organization, and therefore, the ability to create new Teams.

  1. Visit admin.atlassian.com

  2. Select your Organization (if you have more than one)

  3. Select Products

  4. Select User access settings

  5. Select Edit settings for the Any domain entry

  6. Ensure that at least one of your products has the Admin approval "Required" box checked

Please refer to the screenshot of a checked "Required" box inside the admin.atlassian.com interface:

Admin approval required checkbox on a Jira product

Updated on April 11, 2025

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