Errors on the insights panel in a Jira company-managed project board
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Users are encountering issues when opening the insights panel on a Scrum board within a company-managed project.
Diagnosis
The insights panel is not displaying the expected information, though the rest of the features of the board work correctly. You may see error messages in the panel, or you may simply see incomplete, inaccurate, or no data in the panel itself.
Cause
The insights panel gets its data based on the active sprint on the board, which is based on the board's filter. It then organizes this data based on the estimation statistic chosen for the board, and finally checks a user's View aggregated data permission from the project's permission scheme when the panel is opened. Therefore, problems with this panel could be tied to any of these configurations.
Solution
Fix problems with the insights panel on a Jira board
Confirm all of the below items are correctly configured, as the problem could be caused by any one of them, or a combination thereof.
Ensure that affected users have been granted the View aggregated data permission in the project's permission scheme
Can be found in Project settings > Permissions
Make sure your filter specifies a project, and isn't overly broad or complex
Look for use of the JQL keyword "OR," as well as filters based on work item fields
Set the Estimation Statistic in your board configuration
From the board view, select ... (More options) > Configure board > Estimation
In your work items, ensure that you're populating the correct estimation fields
Insights only works with the system default story points field, and can't read data from custom story points fields if you're using them
Make sure your work items are being estimated using the same field chosen for your board estimation statistic
If the main board associated with the Sprint is no longer available, try to restore it or create a new one with the correct settings and configurations
Remember that proper configuration and management of your Jira board are essential for making the most out of Insights.
Also, always ensure that your actions align with the guidelines provided in the official documentation. If the issues persist, contact Atlassian Support for further assistance.
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