Login-free portal asks new users to sign up while creating a request

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

If you use a login-free portal, customers can discover your portal and its help articles via search engines. To send a request, they fill out a form and provide an email address to track the request. They can still finish creating an account in the portal to track the request, but it's not necessary.

When a new user tries to create a request from the login-free portal, a warning message appears asking them to sign up when they enter an email ID in the Confirmation email for column in the request form and that email ID is new to that Atlassian Cloud instance.

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Environment

JSM Cloud

Cause

If account typeInternal is enabled under

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> Products > JIRA Service Management > Customer Access and the new user is from one of the approved domains, then this warning will appear in the login-free portal and ask the user to sign up when they try to raise a request. The internal customer account type is used to grant new internal users with specific product access (like Agent or Customer).

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Solution

You can select one of the following options to remove this warning message from the portal:

  1. Disable Use approved domains to grant internal customers access to the help center with Atlassian accounts under

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    > Products > JIRA Service Management > Customer Access > Account types

    OR

  2. Don't grant any product access to that "Approved Domain"

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Updated on April 8, 2025

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