JSM/OpsGenie: Getting 400 error on creation of Jira Service Management issues when an OpsGenie alert is created

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When using OpsGenie integration with Jira Service Management new or legacy cloud integration creating Jira Service Management issues in some cases fails with the following error: "Field 'xxxx' cannot be set. It is not on the appropriate screen, or unknown":

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Issue might occurs with any field not just labels and same cause/workaround applies.

Environment

Jira Service Management cloud with OpsGenie.

Cause

This issue is experienced when the createIssue action configured in OpsGenie integration contains a field to be populated which is not added to Jira issue screen. So, when we try to create the issue and cannot find the field to set a 400 error code is returned.

Solution

Modify the screen configuration in Jira to include all fields configured in OpsGenie createIssue action

Check fields requirements in OpsGenie integration page

  • Login to your OpsGenie site URL.

  • Go to Teams > Integrations > Select Jira Service Management integration.

  • Under Outgoing automation rule >Create and update requests with Opsgenie alerts that are created by other integrations" > Click on (...) as seen below:

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  • On the Edit request creation rule screen click Edit request fields:

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  • On the Customize request fields screen select All fields and make note of all the fields that are needed for a successful issue creation in Jira:

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Update Jira issue screen with the fields needed for issue creation

  • In Jira, go to the project connected to OpsGenie integration "In which issues should be created" to Project Settings > Issue types > Select the relevant screen as seen below "In our use case OpsGenie integration was set to create an Incident issue type hence this is the screen to be modified in this scenario":

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Additional checks

You can use Find your field feature to check whether the field is added to the issue type or not

You must be an admin to use Find your field on the issue view.

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Updated on April 8, 2025

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