JIRA returns 404 Error when searching for issues
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
The following appears in the atlassian-jira.log
:
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2015-01-01 10:11:12,130 http-bio-8080-exec-22 ERROR captainplanet 699x958x1 1huugh0 10.0.21.36 /secure/IssueNavigator.jspa [jira.web.dispatcher.JiraWebworkActionDispatcher] Exception thrown from action 'IssueNavigator', returning 404
WebworkConfigurationNotFoundException{class=class webwork.config.XMLActionConfiguration, message='No such view mapping', name='IssueNavigator.actionRoles.actionRoles'}
Diagnosis
This issue is seen when upgrading JIRA to newer versions
The following may appear in the logs before the product was upgraded
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jira.plugin.state-.com.atlassian.jira.jira-issue-nav-plugin:kickass-rewrite : false
The log explicitly reports the following in the Error message:
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name='IssueNavigator.actionRoles.actionRoles'
Cause
This is caused by a disabled plugin which is required for JIRA to complete searches in newer versions of the product. This may be Jira Software, if it is not installed/initialized properly, the boards will not display and a 404 error code is returned.
Solution
Resolution
There are two methods to resolve this issue, either through modifying the database or using a backup file.
Database Method
Always back up your data before performing any modification to the database. If possible, try your modifications on a test server.
Execute the SQL below to check for any disabled plugin(s):
JIRA 6.0.X and earlier
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SELECT * FROM propertyentry e JOIN propertystring s ON e.id=s.id WHERE e.property_key LIKE '%plugin.state%';
JIRA 6.1.X onwards
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SELECT * FROM pluginstate where pluginenabled = 'false';
If this query does not return any rows, then the resolution outlined in this document is not applicable for your JIRA instance. If there are valid rows returned, then please proceed to step number 2.
Enable any plugin(s) that is disabled using the SQL query below:
JIRA 6.0.X and earlier
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UPDATE propertystring SET propertyvalue='true' WHERE id='com.atlassian.jira.jira-issue-nav-plugin:kickass-rewrite';
JIRA 6.1.X onwards
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DELETE from pluginstate WHERE pluginkey='com.atlassian.jira.jira-issue-nav-plugin:kickass-rewrite';
Backup Method
Take an XML Backup as per: Backing Up Data.
Extract the entities.xml file from your backup file.
Search for jira-issue-nav-plugin inside the entities.xml file, this should return:
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<OSPropertyEntry id="32115" entityName="jira.properties" entityId="1" propertyKey="jira.plugin.state-.com.atlassian.jira.jira-issue-nav-plugin:kickass-rewrite" type="5" />
Then, search for the matching "OSPropertyString" which should returned:
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<OSPropertyString id="32115" value="false" />
Replace "false" with "true" and saved the file.
Restore the backup into your environment.
ℹ️ This issue has a log entry that is similar to another problem: JIRA Links Menu Errors due to Communication Breakdown
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