Getting 403 error and “The value could not be saved” when setting Request Type

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When you try to edit the Request type on an issue after moving it or changing its issue type, you get the error "The value could not be saved."

Diagnosis

Due to JSDCLOUD-1835 - Update request type upon issue type change moving an issue from one project to another or changing the issue type requires an update to the Request Type. This sometimes results in error:

Cause

You see this error due to the workflow property set on the status that doesn't allow a user to edit the issue anymore. When the workflow property jira.issue.editable set to false in the workflow, it prevents users from editing an issue in that status.

More details on properties can be found in Use workflow properties

Solution

You need to remove the workflow property to allow any fields to be editable in a particular status.

Steps to resolve this issue:

  1. Identify the issue type and the status where you get the error.

  2. Navigate to the workflow that is associated with the affected issue type in Step 1: Project Settings → Workflow → Edit (Click on the pencil icon under Actions) > Click on the "Diagram" tab

  3. Select the status identified in Step 1, on the pop-up click on Properties

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  4. Delete the workflow property (jira.issue.editable)

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  5. Publish the workflow to save the changes

If you just wish to restrict the ability to edit certain fields, then you don't need to add jira.issue.editable workflow property. Instead, you need to remove those fields from the Edit Screen of that Issue type.

For example, you want nobody to change the summary or description field, then you can delete the jira.issue.editable workflow property and remove the Summary or Description field from the Edit Screen (Project Settings → Screens → Select the one associated with the affected Issue type and remove the fields)

Updated on February 27, 2025

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