Fix Tunnelled Application Link Error: "The tunnel isn't working, but we couldn't find an exact cause"

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When running the Application tunnel configuration, you notice a failure on the cloud site. The error displayed is

The tunnel isn't working, but we couldn't find an exact cause. This is usually related to your self-managed instance, so please verify that everything is functioning correctly or consult the documentation for additional solutions.

This article will outline possible causes and fixes.

Diagnosis

The application tunnel displays an error message stating,

"The tunnel isn't working, but we couldn't find an exact cause. This is usually related to your self-managed instance, so please verify that everything is functioning correctly or consult the documentation for additional solutions."

This issue appears on the Application Tunnels configuration page, even though the connection status indicates that it is connected to the on-premises Jira Data Center instance.

Use the following to check the configuration:

Cause

The modification of the conf/server.xml file is done to restrict connections from localhost. However, the application tunnel expects the hostname to be accessible via localhost.

Solution

Update the conf/server.xml file to include an alias localhost before the end of tag "</Host>".

Example:

<Alias>localhost</Alias> </Host>

Updated on June 3, 2025

Still need help?

The Atlassian Community is here for you.