Fix 400 errors with JSON payloads in Google Chat webhooks via Jira Cloud automation

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Discover solutions for the 400 error in Jira Automation when sending JSON payloads to Google Chat webhooks.

Diagnosis

Users may encounter a 400 error when sending JSON payloads to Google Chat webhooks. This is often due to the specific JSON format required by Google Chat, which may not align with the payloads generated by Jira Automation using smart values.

Cause

Google Chat webhooks require a specific JSON payload format, primarily a text field at the root level. Opsgenie’s webhook payloads, often used in conjunction with Jira Automation, don't match this format, leading to errors such as:

Invalid JSON payload received. Unknown name "action" at 'message': Cannot find field. Invalid JSON payload received. Unknown name "alert" at 'message': Cannot find field. Invalid JSON payload received. Unknown name "source" at 'message': Cannot find field.

Solution

Recommended solutions

  • Zapier:

    • Allows you to receive webhooks from Opsgenie, transform the payload, and send a new webhook to Google Chat.

    • Easy to setup with a visual workflow editor.

    • Suitable for simple use cases and quick prototyping.

    • Zapier Integration

  • Other Middleware Options:

Feature Requests

For users interested in native support for Google Chat integration, please refer to the following feature requests:

Additional Resources

Updated on June 16, 2025

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