"This request is only available to users with Jira access" error in Jira Service Management

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

Learn why customers can't raise requests in the portal, with the error "This field is only available to users with Jira access."

Diagnosis

When customers attempt to submit a request via portal the request is not submitted and they see the error:

We couldn't load this request This request is only available to users with Jira access. Select a different request, or contact your admin.

Cause

Customers can't use the Affected Services fields

The Affected Services field is only available to licensed users. These error messages are specifically linked to when you link a Form field to the Jira field Affected Services. A user who is only a customer can't interact with it and can't submit a request.

We have a feature request to improve this:

Solution

Manually or automatically update the Affected Services field

Manually update the field

For starters, in the form builder, unlink the Jira field Affected services and add the same choices in the form field as those in the Jira field. This will allow customers to select an Affected Service and have this input stored in the Form field.

The first solution is for the agent to manually fill out the Jira Affected Services field based on the customer's selection in the Form field.

Use automation to update the field

A more effective approach is to have an automation rule copy the value from the Forms field (that is linked to a custom Jira custom field) into the system Affected Services field.

  1. Create a custom Jira field of type Select List (single choice) and update the same values from the Affected Services system field.

  2. Link the custom field to the Forms field.

  3. Create an automation rule to update the system field based on the value from the custom Jira field:

    1. Select Trigger: work item created.

    2. Add a Condition: IF or ELSE.

    3. On the IF branch created, add the condition IF: Custom field equals fieldvalue.

    4. Inside the same IF branch, add an Action: edit work item.

      1. Expand More Options and use Additional fields to update the system Affected Services using: Refer to this article to find the specific ID of your custom field and replace it in the code above.

        { "fields": { "Affected services":[{"id": "{{issue.customfield_10181}}"}] } }
    5. Add more IF-ELSE branches and repeat steps 3 and 4 to catch all values in your Affected Services field.

Updated on June 20, 2025

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