Can't see workflow option when changing a Request Type's workflow on service projects
Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.
Summary
Learn why you may not be able to select the desired workflow when trying to replace the workflow of a request type in Jira Service Management cloud projects.
Diagnosis
When you attempt to replace the workflow of a request type, you're unable to find and select the desired workflow in the Select workflow field.
Cause
Workflow is inactive
This happens because the target workflow is not associated with any projects or work types and is considered an Inactive Workflow.
Solution
The solution will depend on your desired use case:
If you don't want to change the workflow of other request types using the same work type in the project:
In this scenario, you will need to associate a different Work Type with your project (or create a new work type and then associate it).
Associate the target workflow with the above work type on the project's workflow Scheme.
Repeat the attempt to change the Request Type workflow. This time, the target workflow will appear as an option.
If you don't mind changing the workflow of all Request Types to use the same work type as the one you are trying to change.
You can associate the target workflow directly with the work type on the project's Workflow Scheme.
Please be aware that all open requests using this same work type will also be updated to the new workflow.
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