Atlassian Assist: "An error occurred while loading the issue details" in JSM Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When editing a Request in Slack via Atlassian Assist (JSM Chat), the Slack Modal will return an error:
Something went wrong.
⚠ An error occurred while loading the issue details.
Share this error ID with support: <error id>
Diagnosis
Atlassian Support can use the error ID to check our backend logs and determine what the root cause is.
Cause
Slack Modals have a hard limit of 100 Fields: https://api.slack.com/surfaces/modals
blocks Array Required. An array of blocks that defines the content of the view. Max of 100 blocks. |
When Assist tries to provide more than that, an error occurs.
Solution
Reduce the number of Fields to fewer than 100. Be mindful of system fields like Shared With, which can't be removed.
Which User is editing matters, because Agents can usually see more Fields than Customers. In that case, check the Screen for the Issue Type for a source of how many Fields are present.
The Issue itself can have more Fields with Data than the limit. The problem is when more than 100 of those are editable:
Verify the Request Type's Field Count
Verify the Edit Screen's Field Count
And, if you'd like, check the total list of Fields on the Issue regardless of the above: Find all available smart values for a Jira issue
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