Resolve Activity Stream Gadget Error in Jira
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When attempting to access the Dashboard gadget Activity Stream, it fails to load and throws the error message "An error occurred while trying to retrieve recent activity".
Additionally, the gadget will not allow you to edit its configuration, and an error will be displayed ("Oops - an error has occurred").
Diagnosis
Navigate to an existing Dashboard and select Edit. You can also create a new one.
Once in your Dashboard, add or edit an Activity Stream gadget. For more information about adding a gadget to your Dashboard, please refer to the article Add a gadget to a dashboard.
In the Activity Stream gadget, click on the three-dot menu and select Configure. Complete the setup according to your requirements, and click the Save button.
Then, click on the Done button on the Dashboard.
If the problem described below in the Cause section is present in your instance, you will get the error message "An error occurred while trying to retrieve recent activity" when the gadget tries to retrieve the information.
Cause
The Activity Stream gadget gets data from Jira and other connected apps through all set application links. Hence, the error could be caused by an issue in the related application link.
Solution
To check if any Application Link is failing, select Settings (⚙), then Products. Select Application Links in the left menu and check the status of the Application Links. The status could also be showing difficulties in loading:

Try to recreate the connection and review the Activity Stream gadget again. In most of the cases, this solves the problem.
For more details about troubleshooting Application Links, please refer to the Application Links Troubleshooting Guide.
Was this helpful?