Transferring cloud site URL to another site

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

Sometimes, admins assign a URL to an Atlassian Cloud site that they intended to assign to a different site. This creates a problem, as the URL will remain associated to that site until the site is deleted.

Environment:

Cloud, Requires a Standard subscription or higher

Diagnosis

If you have a Standard subscription or higher, you can update your site URL subdomain using the steps in Update a product URL. This does not remove the original site URL from your site, but leaves it as a redirect to your site.

If you change the site URL for the site that has the desired URL, this does not cause that URL to be made available for another site.

Cause

Cloud site URLs are permanently bound to a site once assigned. Changing a site's URL to a new subdomain does not release the original URL — it remains as a redirect. There is currently no self-service option to unassociate or transfer a URL between sites, so the original URL cannot be reused by another site unless the owning site is deleted or Atlassian Support manually performs the transfer.

Solution

There are two options to resolve this:

Option 1: Cancel your subscriptions on the site with the desired URL and wait for the site to be deleted. The URL will be released 30 days after deletion and will then be available for use on another site.

Option 2: Request that the original site URL be transferred to the new site. This requires that you are an administrator for both sites and have at least a Standard application subscription. Follow the steps below:

  1. Review the section What happens after the URL is updated in Update an app URL subdomain | Atlassian Support to understand the potential impacts of this change and confirm that they are acceptable.

  2. If you have not already, create the site that will be the destination for the URL.

  3. Ensure that you are an administrator for both sites. To verify, access the URL in the format https://siteurl/admin and confirm that the Users page displays without errors.

  4. Open a request with Atlassian Support at Atlassian Support.

    1. Select Technical issues and bugs from the initial drop-down.

    2. Select Cloud administration as the application.

  5. In your request, clearly specify the source and destination site URLs for the transfer, and any other requirements.

A feature request has been logged to add the ability to unassociate a URL from a site so that it can be reused without the process above: CLOUD-11953

Updated on May 29, 2026

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