SourceTree crashes on startup
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
When attempting to start SourceTree, the following dialog is displayed with the message "SourceTree has stopped working", and the application does not start:

Diagnosis
Diagnostic Steps
Open the Event Viewer in Windows right after the crash
Go to Windows Logs >> Application
There should be two Error entries.
One of them has as Source: .NET Runtime
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Application: SourceTree.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.Configuration.ConfigurationErrorsException Stack: at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean) at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(System.Configuration.ConfigurationSchemaErrors) at System.Configuration.Configuration..ctor(System.String, System.Type, System.Object[]) at System.Configuration.ClientConfigurationHost.OpenExeConfiguration(System.Configuration.ConfigurationFileMap, Boolean, System.Configuration.ConfigurationUserLevel, System.String) at System.Configuration.ConfigurationManager.OpenExeConfigurationImpl(System.Configuration.ConfigurationFileMap, Boolean, System.Configuration.ConfigurationUserLevel, System.String, Boolean) at SourceTree.App.SetStartupJIT() at SourceTree.App..ctor() at SourceTree.App.Main()
The second one has as Source: Application Error
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Faulting application name: SourceTree.exe, version: 1.8.3.0, time stamp: 0x56f18db8 Faulting module name: KERNELBASE.dll, version: 6.1.7600.16385, time stamp: 0x4a5bdfe0 Exception code: 0xe0434352 Fault offset: 0x000000000000aa7d Faulting process id: 0xb54 Faulting application start time: 0x01d1d3a51746a7d1 Faulting application path: C:\Program Files (x86)\Atlassian\SourceTree\SourceTree.exe Faulting module path: C:\Windows\system32\KERNELBASE.dll Report Id: 550f6aff-3f98-11e6-a681-0800279df20e
Cause
The most likely reason for this error is that the user.config file for SourceTree has been corrupted.
You can confirm this by locating the file in this location:
C:\Users\<User>\AppData\Local\Atlassian\SourceTree.exe_<random_string>\<version_number>
If this is the cause, when you open the file, it will be full of <NULL> values.
Solution
Resolution
If the user.config file is indeed corrupted, you may delete it.
It will be regenerated the next time you start SourceTree, and the application should start normally.
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