Email are not created as an issue from the IMAP server (Microsoft Exchange). Errors appear such as:

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

A4 BAD Command Argument Error. 11

The following appears in the atlassian-confluence.log:

1 2 3 4 5 6 7 8 9 10 11 12 JiraQuartzScheduler_Worker-3 ERROR [service.services.mail.MailFetcherService] Create Issue/Comment Service - ...[...]: Exception: A4 BAD Command Argument Error. 11; nested exception is: com.sun.mail.iap.BadCommandException: A4 BAD Command Argument Error. 11 javax.mail.MessagingException: A4 BAD Command Argument Error. 11; nested exception is: com.sun.mail.iap.BadCommandException: A4 BAD Command Argument Error. 11 at com.sun.mail.imap.IMAPMessage.getHeader(IMAPMessage.java:624) at com.atlassian.jira.service.services.mail.MailFetcherService.run(MailFetcherService.java:175) at com.atlassian.jira.service.JiraServiceContainerImpl.run(JiraServiceContainerImpl.java:56) at com.atlassian.jira.service.ServiceRunner.execute(ServiceRunner.java:61) at org.quartz.core.JobRunShell.run(JobRunShell.java:191) at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:516)

Cause

The Microsoft Exchange server is installed with Turkish Regional Settings. The uppercase/lowercase conversion from the Microsoft Exchange server to JIRA is not working

Resolution

  1. On the Windows Server where Exchange is installed, go to Control Panel.

  2. Click on Regional Language.

  3. In format tab, change the format to English (US) and click Apply.

  4. Goto Adminsitrative Tab, Change the system locale to English US and Restart Exchaneg Server.

  5. Once restarted, Goto Regional Language again, goto Administrative Tab and and click on copy the settings.

  6. Tick the "Welcome screen and system accounts" and "new user accounts" boxes and click ok in order to change all of them to English.

  7. Restart and check if your issue is gone.

    ℹ️ info is good

Updated on April 8, 2025

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