"Download your SourceTree license" link is broken on my.atlassian.com

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

"Download your SourceTree license" link is broken on my.atlassian.com.

(Auto-migrated image: description temporarily unavailable)

Cause

When it comes to the latest SourceTree, you no longer have to manually download the license and install it into SourceTree.

All you have to do for using SourceTree is just login Atlassian Account once when you set up it instead.

Resolution

Please ignore the broken link and set up the latest SourceTree following these instructions.

Updated on April 11, 2025

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