Resolve Slack integration disconnect and reauthorization issues in Rovo

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Learn how to resolve issues disconnecting, reconnecting, or reauthorizing the Slack integration in Rovo.

Diagnosis

You may be experiencing one of the following issues with the Slack integration in Rovo:

  • Unable to disconnect the Slack integration; the process is stuck in a 'disconnecting' state.

  • Unable to reconnect or reauthorize the Slack integration.

  • Encountering a generic error message during the reauth process.

Cause

Problems may arise if the Slack app isn't fully revoked or if removal is delayed. Permissions or session issues can also cause errors during reauthorization. Disconnecting a third-party app from Rovo, like Slack, may take up to 48 hours.

Solution

Manually revoke the Slack app from Connected apps

  1. Click your profile icon and select Manage.

  2. Go to the Connected apps tab.

    1. You can also access the direct link here.

  3. Search for Rovo Slack.

  4. Revoke all Rovo Slack apps listed.

Reauthorize or disconnect the Slack integration

If you are trying to reconnect or reauthorize:

  1. Return to the previous page in Rovo.

  2. Click Re-auth to attempt reauthorization.

If you are trying to disconnect:

  1. Wait up to 48 hours for the Slack connector to be fully removed from Rovo.

If the issue persists

If the Slack integration is still present or you continue to receive error messages after 48 hours:

  1. Capture a HAR file while reproducing the issue.

    1. Learn how to generate a HAR file.

  2. Provide the HAR file to Atlassian support for further investigation.

References

Updated on May 31, 2025

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