"You don't have access to view all related commits. Please contact your administrator." message while trying to view commit

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

  • JIRA and Fisheye is linked using an application link. ( Can also be applied to other applications like Confluence, and Bitbucket Server ).

  • Commits can be viewed from the development panel in JIRA issues.

  • The problem is that users are not able to open the recent commits directly from the JIRA issue, although the user is able to open them in Fisheye.

  • The user is already associated with the appropriate groups.

Cause

OAuth with 2-legged OAuth request is not enabled as the application link might be configured using Trusted or Basic Authentication.

Resolution

  1. Re-create or edit the application link on both application sides to ensure that the Incoming and Outgoing Authentication is only using OAuth with 2-Legged OAuth request enabled.

  2. Ensure that Trusted and Basic authentication is disabled.

Updated on April 11, 2025

Still need help?

The Atlassian Community is here for you.