Wrong Custom Field Displayed on an Issue Screen
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When seeing a Screen in JIRA, a different Field is displayed rather than the one configured. You can see in the example below that the Story Points field is being displayed three times in the screen:

However, looking on the Screen configured for this Project/Issue Type, the original fields are correctly configured, and the Story Points is only appearing once:

Cause
The Field Configuration of the custom field is mistakenly pointing to the Field Configuration of another Custom Field instead of it's own. This is similar to the problem described on this other knowledge base article, but what causes both of these problems is still unknown.
Resolution
Please remember to backup your data before making any modifications in the database! Also, remember to shutdown JIRA before making the changes, and only restart it after all the modifications are done.
First of all, get the id of the Custom Field being mistakenly displayed:
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select * from customfield where cfname = '<CustomFieldName>';
For example, '10002' will be returned. So replace '10002' in the following queries with the id you got from the query above.
Then, verify what are the incorrect entries. To do so, please run the following:
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select * from fieldconfigschemeissuetype where fieldconfiguration in (SELECT id FROM fieldconfiguration WHERE fieldid = 'customfield_10002') AND fieldconfigscheme not in (select id from fieldconfigscheme WHERE fieldid = 'customfield_10002');
Here it should be returned one row for each association between the corrupt custom field and an issue type. For example, if the field is associated with two Issue Types, two rows should be returned. (Please note it is possible more than one custom field is being affected).
Using the value of the 'fieldconfigscheme' returned, run the following:
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select * from fieldconfigscheme where id = 14902;
If more than one custom field is being affected, you'll see different values in the 'fieldconfigscheme' column, and in this case choose one of them. Keep the value of the 'fieldid' returned, which will be used in the queries below. (e.g. 'customfield_14302').
Now, run the below to get the correct 'fieldconfiguration' of the custom field to correct the association:
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select * from fieldconfiguration where fieldid = 'customfield_14302';
Replace 'customfield_14302' with the value returned in the previous step. Also, keep the value of the 'id' returned for future use (e.g.: 15502).
With the data gathered with the previous queries, run the following query to correct the associated values and consequently fix this issue:
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update fieldconfigschemeissuetype set fieldconfiguration = 15502 where fieldconfigscheme = 14902;
You'll just need to replace the fieldconfiguration value with the one returned on step #4 and fieldconfigscheme with the one used in step #3.
After that, one of the fields will already be corrected, so you'll need to follow steps #2 to #5 again if more than one Custom Field is being affected.
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