Work Log tab is empty or doesn't display all information
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When viewing an issue, the Work Log tab is either empty or doesn't display all work logs

However, the History tab shows that work is indeed logged

Cause
When entering the work log, the user restricted this entry to certain Roles/Groups

The logs will appear if a user part of this role views the issue
User part of the restricted role
User not part of the role
Resolution
If you want all work logs to be displayed, then you will have to manually change the work logs such that they are not restricted
Log in as a user who can view the work log
View the issue's work log tab
For the affected entry, hover over it and click on the pencil icon on the top right of it
Edit the entry so that All Users can view it
You can run the following queries against your JIRA database to find the affected issues (these queries are written for PostgreSQL. Modification might have to be made to suit the database your JIRA is using)
To find all work logs which are restricted to certain Roles
1
SELECT a.pkey, b.issuenum, c.author, d.name AS "Role" FROM project a JOIN jiraissue b ON a.id=b.project JOIN worklog c ON b.id=c.issueid JOIN projectrole d ON c.rolelevel=d.id WHERE c.rolelevel IS NOT null ORDER BY pkey, issuenum;
To find all work logs which are restricted to certain Groups
1
SELECT a.pkey, b.issuenum, c.author, c.grouplevel FROM project a JOIN jiraissue b ON a.id=b.project JOIN worklog c ON b.id=c.issueid WHERE c.grouplevel IS NOT null ORDER BY pkey, issuenum;
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