Wiki Toolbar is not visible in Comment field

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When you navigate to the issue detail page and add a comment, the wiki editor toolbar is not visible despite of the following:

  1. Comment field from Field Configuration is set to Wiki Style Renderer.

  2. Wiki Editor system plugin and all of it's modules are enabled.

Diagnosis

  1. Enable the Developer console before accessing the issue detail page.

(Auto-migrated image: description temporarily unavailable)
1 2 Uncaught Error: wiki-edit/WikiEnabledTextarea missing featureflags/feature-manager batch.js:216

2. Check the pluginstate table and see if "com.atlassian.pocketknife.featureflags-plugin" is disabled.

Resolution

  • Enable "com.atlassian.pocketknife.featureflags-plugin" from the database and restart JIRA.

1 DELETE from pluginstate where pluginkey = 'com.atlassian.pocketknife.featureflags-plugin';
Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.