Why is the release delayed or not meeting the release date?

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

All tickets show taking until the release date of the next release.

Diagnosis

Portfolio has scheduled multiple issues from different releases to start at the same time.

Possible Causes

  • Fixed dates assigned to issues are overlapping

  • Both Teams and Users are assigned to issues. This makes the plan less flexible, and Portfolio is forced to use this schedule which is not very efficient.

Resolution

  1. Select All Releases in the plan filter.

  2. Check if Releases have fixed dates that are overlapping.

  3. Make sure both Teams and Users are not assigned to issues.

Updated on April 8, 2025

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