Why is the Column for Custom Field not Showing in the Issue Navigator?

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

A custom field is configured, and added to the Issue Navigator column order, but still not visible.

Diagnosis

  1. Check if the Custom Field has any value for the issues listed.

  2. Verify the custom field is set to a Global Issue Type Context, in the Adding a Custom Field.

Cause

The field has no value, or it has not been defined in a global Issue Type context.

Solution

Resolution

  • Give the custom field a value

    OR

  • Define the Custom Field's Issue Type context to be global

    ℹ️ See more here on Adding a Custom Field

Updated on April 2, 2025

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