Why DNS checker for setting up custom domain email address still "Unverified" in Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
As an organization admin, you can set up DMARC so that Jira project admins can customize the sender email address of any Jira project notifications, including customer notifications for Jira Service Management. The detailed steps are explained at https://support.atlassian.com/organization-administration/docs/what-are-the-steps-for-setting-up-custom-email-addresses/ documentation. But sometimes, the DNS checker still shows UNVERIFIED.
Environment
JIRA Cloud
Diagnosis
Go to admin.atlassian.com and access your organization configuration.
Then, go to Settings > Email > Email Domains
For Status, it still shows UNVERIFIED

Cause
In order to verify successfully, all the DNS record values must be exact as in the DNS records in the configuration. As for SPF configuration, if it has multiple entries, the value must be valid.

Solution
To verify txt for SPF records.
By default, it must have the value below
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include:_spf.atlassian.net
To verify , go to Terminal and use the command below:-
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dig -t txt domain.com
Look for v=spf1 record. Verify if it has the correct value. If it have multiple record , follow the steps in How to merge multiple SPF record page.
You may also verify the SPF record from SPF Lookup from MXToolbox page.
To verify the CNAME record for DKIM Active , DKIM Fallback, and bounce record
Copy the CNAME DKIM Active name , for example :-
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atlassian-8d2d08._domainkey.test.org
Then , go to Terminal and use the commad as below:-
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dig -t atlassian-8d2d08._domainkey.test.org CNAME
Compare the value with the DNS record value in admin.atlassian.com. The value must be matched.
You can also verify from CNAME lookup from MXToolbox
Do the same steps for other DKIM values.
To verify the txt for Verify record
Do the same steps as verifying the SPF.
Make sure the record value matched. For example :-
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atlassian-sending-domain-verification=7cdfa26d-9f6c-47ab-abbc-4455a396253c
You can also use the TXT Lookup from MXToolbox
Once all the records are matched, click the Run DNS records check.
It will process for some time. If it is still not updated, give a time and click the button again. It will verify successfully.
In case the problem still happening, raise a ticket to us and we will help you to investigate further.
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