Troubleshoot Unverified DNS Checker for Custom Domain Email in Atlassian Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Organization admins can set up DMARC for custom sender emails in Jira, but the DNS checker may show UNVERIFIED.

Diagnosis

  1.  Go to admin.atlassian.com and access your organization configuration.

  2. Then, go to Settings > Email > Email Domains.

  3. For Status, it still shows UNVERIFIED.

Cause

In order to verify successfully, all the DNS record values must be exact as in the DNS records in the configuration. As for SPF configuration, if it has multiple entries, the value must be valid.

Solution

To verify txt for SPF records

  • By default, it must have the following value:

    include:_spf.atlassian.net
  • To verify, go to Terminal and use the command below:

    dig -t txt domain.com
  • Look for v=spf1 record. Verify if it has the correct value. If it has multiple records, follow the steps in How to merge multiple SPF records.

  • You may also verify the SPF record from SPF Lookup from MXToolbox page.

To verify the CNAME record for DKIM Active, DKIM Fallback, and the bounce record

  • Copy the CNAME DKIM Active name, for example:

    atlassian-8d2d08._domainkey.test.org
  • Then, go to Terminal and use the command as below:

    dig -t atlassian-8d2d08._domainkey.test.org CNAME
  • Compare the value with the DNS record value in admin.atlassian.com. The value must be matched. 

  • You can also verify from CNAME lookup from MXToolbox.

  • Do the same steps for other DKIM values.

To verify the txt for the Verify record

  • Do the same steps as verifying the SPF. 

  • Make sure the record value matches. For example:

    atlassian-sending-domain-verification=7cdfa26d-9f6c-47ab-abbc-4455a396253c
  • You can also use the TXT Lookup from MXToolbox.

  • Once all the records are matched, click the Run DNS records check

  • It will process for some time. If it is still not updated, give a time and click the button again. It will verify successfully.

  • If the problem persists, raise a ticket with us, and we will help you investigate further.

Updated on May 1, 2025

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