Troubleshoot Missing Fields on Jira View Work Item Screen - Jira Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Some users report they don't see some fields despite the field context being configured correctly, and the fields added to the issue layout.
Cause
The fields that are not populated only show up for users who can edit the work item. If you are not allowed to edit the work item, you will not be able to populate the empty fields, and hence you will only see fields that already have a value.
Example of Work item Details:

Without Edit permission | With edit permission | |
---|---|---|
Assignee | has value -> ✔️ | has value -> ✔️ |
Reporter | has value -> ✔️ | has value -> ✔️ |
Priority | has value -> ✔️ | has value -> ✔️ |
Labels | ❌ | ✔️ |
Components | ❌ | ✔️ |
Core Team | ❌ | ✔️ |
Parent | ❌ | ✔️ |
Story Points | ❌ | ✔️ |
Source | ❌ | ✔️ |
Similarly, if there are multiple tabs on your issue view screen, only the fields that have at least one field populated will be visible to the users without the Edit Issues permission.
Solution
Follow these steps to give Edit Issues permission to users or groups:
Go to Project Settings > Permissions.
Select Actions and then Edit Permissions from the top right of the page.
This will open up the permission schemes page. Select Update against the Edit Issues permission.
Add the required users, groups, project roles, or issue roles.
Click Update, and the change will take effect immediately.
Multiple projects could be using the same permission scheme, so the changes will take effect for all the projects. If you would like to implement the change for one project only without switching to a different permission scheme, you may grant the Edit permission to a particular project role and assign users with the project role only in the required projects.
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