Request type fields Display names is not showing correctly in the customer portal

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Learn why the Display name for a field is not reflected in the portal view for that request type.

Diagnosis

You have customized a request type, configuring Display names for fields in its request form, but customers report they see something different on the customer portal request form.

Cause

Language support is not updated

The affected customer account's Preferred Language is different from the default language set in the service project (Project Settings > Language Support).

For example, the customer's account language may be set to English (UK) while the service project's default language may be set to English (US) instead.

Solution

Update or remove a language from the project

There are 2 ways to resolve this issue:

  1. Make sure all languages are updated on Project Settings > Language Support.

  2. Remove the language from the service project so customers will view the portal in the project's default language. For example, remove English (UK) from the service project's language support if the default language of the project is English (US).

Updated on June 19, 2025

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