While creating an issue, Project field not showing all the projects available

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

While using the Create option to create an issue, all the projects are not visible in the Project field.

Environment

Jira Cloud

Cause

This behavior is by design:

  • The Project field uses a picker that limits how many projects are displayed at once to keep the dropdown fast and responsive, especially on sites with many projects.

  • Only a subset of projects (for example, your recent projects plus a small number of others) is shown initially.

  • To access the full set of projects, the user should have permission to create issues in, and they should type part of the project’s name or key to search.

This is a product limitation of the dropdown and not a bug. It is separate from permission issues:

  • If a project does not appear even when the user search for it by name/key, it is likely because they do not have Create issue permission in that project, or they do not have access to the project at all.

Solution

To select a project when it is not visible in the dropdown:

  1. Click Create in the Jira header to open the Create issue dialog.

  2. Click into the Project field and a project list is visible that typically includes:

    • Recent projects, and

    • All projects section showing a limited number of projects.

  3. If the required project is not in the visible list, click into the Project field and start typing the project’s name or key.

    • When the user starts typing the name of a project, Jira should provide matching suggestions, allowing the user to select the correct project even if it doesn't initially appear in the list. This means that the user needs to know at least part of the project's name.

  4. When the correct project is visible in the list, click it to select it.

Updated on March 17, 2026

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