When running Jira installer on Windows Server 2012 and higher the download may be blocked
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When attempting to run the Jira installer .exe file on a Windows Server 2012 or higher server, the installer may fail to run with a warning message:
'Microsoft Defender SmartScreen prevent an unrecognized app from starting. Running this app might put your PC at risk'
Another possibility is that the installer may appear to run but pop up messages during the installation note that there were issues copy DLLs to the bin directory.
Environment
Microsoft Windows Server 2012 and higher
Diagnosis
This can manifest itself in a few different ways depending on the version of Windows being utilized.
The installer will not run at all. Attempting to run the installer as an Administrator or standard user results in the Microsoft Defender error referenced above.
On some versions of Windows, the installer may appear to execute when running as an Administrator, however you will see messages noting that certain operations like registry updates or moving/writing of DLLs to specific directories failed.
Cause
Windows Server 2012 and higher machines can block files that deemed to be "potentially dangerous" when downloaded. This often includes .exe, .dll or .msi files. Since the Jira installer is a .exe file, often times Windows will block the installer download which can lead the installer to not run properly when executed.
Solution
Unblock the installer and make sure to execute it as an Administrator as described below:
Right-click on the Jira installer .exe file and select Properties.
At the bottom of the window select the 'Unblock' checkbox and choose Apply.
Once the file is unblocked, run the installer executable as an Administrator.
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