When importing issues from a CSV file, some field values are not imported

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

When importing issues from CSV, not all fields are imported. Some fields are blank/not set in all the imported issues.

No import-related errors are logged.

Diagnosis

In the workflow associated to the issues and issue types you're importing, look for post-functions in the "Create" transition.

Cause

Issues imported from CSV are created via the REST API. The "Create" transition is run before the statuses of the issues are flipped to the ones in the CSV.

In some cases, this transition has post-functions that clear certain fields, especially the ones that are set on other transitions.

Solution

Workaround

  1. Temporarily disable the post-function(s) from the workflow.

  2. Import the issues from CSV.

  3. Enable back the post-function(s) from the workflow.

Updated on April 8, 2025

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