When exporting issues to an Excel file, The Excel file contains two rows for each issue.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

In the issue navigator, when creating an Excel file using the "Views -> Excel (all fields)" menu, the Excel file is created successfully, but each issue has two rows.

The following is an example screenshot of the the two rows present for each issue:

(Auto-migrated image: description temporarily unavailable)

As we can see, row 5 and 6 are both used for issue XXX-5. The same is true for other issues.

Diagnosis

There are two ways to check the root cause:

  1. Check the JIRA Version, if it is JIRA 4.2, you can refer to this bug ticket: JRASERVER-22618 - Excel Export adds the issue key to the Project column & an extra blank row between records, which has been fixed in JIRA 4.2.2.

  2. If you are running JIRA 5.X, run JIRA in a safe mode. This will disable all your user-plugins temporally. In the safe mode, generate an .xls file again and the problem should disappear.

Cause

The cause is unknown, as is often the case for third party plugins. Some of the plugins that might cause this problem are:

  • JIRA Gantt-Chart third-party plugin.

  • TestFLO for Test Management

Solution

Workaround

Disable/uninstall the plugin when performing Excel exports.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.